www.ctrt.net > 将spring3升级到spring4.2 后使用定时任务quArtz报错

将spring3升级到spring4.2 后使用定时任务quArtz报错

这个问题应该是jar不兼容的问题! Spring针对quartz的支持是有严格的版本要求的 一般都是spring3.2.2配quartz2.2.1那一整套最稳定,但是Spring不同的版本的quartz,spring就不行了,里面针对spring中的JobDetailFactoryBean类不支持,详细情况需...

楼主。。。你的quartz的jar包有没有导入?

http://blog.csdn.net/cgs1999/article/details/3997163

是不是类似这种哦?我这在用的有个小项目。

你在action中再写一个方法all(),调用text1,text2,text3,然后在spring quartz中调用all().........

public class MyQuartzJobBean extends QuartzJobBean { private SimpleService simpleService; @Autowired public void setSimpleService(SimpleService simpleService) { this.simpleService = simpleService; } @Override protected void ex...

如下错误在哪里?

String.prototype.sub = function (n) { var r = /[^\x00-\xff]/g; if (this.replace(r, "mm").length = n) { return this.substr(0, i); }

兄弟,你点进去这个类org.springframework.scheduling.quartz.JobDetailBean看看他的提示啊!! NOTE: This convenience subclass does not work against Quartz 2.0. Use Quartz 2.0's native JobDetailImpl class or the new Quartz 2.0 builder 。

虽然没有看到你的错误信息,但是你用的spring3,quartz2,应该会出现版本不兼容,quart换成1.8的

网站地图

All rights reserved Powered by www.ctrt.net

copyright ©right 2010-2021。
www.ctrt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com