www.ctrt.net > 用myEClipsE开发的jAvAwEB项目当导入import jAvAx....

用myEClipsE开发的jAvAwEB项目当导入import jAvAx....

因为你还没有导入servlet-api.jar包 导入方法:右键你的工程属性,然后如图 选择导入的外部jar要到你的tomcat安装目录下的bin目录下选择servlet-api.jar

MyEclipse里面集成了很多jar eclipse需要自己手动去设置你的工程所需要的jar HttpSession 可能是tomcat中的serlet-api的jar 你去你的这个工程的bulidpath看下 有没相关jar

得加入tomcat的jar包,右击项目->build path-add libraries->server Runtime->选择要导入的tomcat 就可以了,如果没有选项,你得配置tomcat

如果eclipse有集成web,eclipse就已经自带了这些包。右击web项目——properties——Java Buid Path——Libraries——Add Library——Server Runtime——next——选择运行时的web 容器(如tomcat),这样子就能在项目中导入了。

错误提示是没有引入javax.servlet.http.HttpServletRequest所在的包,编译错误。 这么添加: 项目-->右键-->properties-->java build bath-->Libraries 这里要保有这两个包。 如果你的没有,那么:add Library-->user Library-->user Libraties-...

学习啦,解决后记得公布下哟

手动添加一下tomcat依赖就行了

可能是Java EE 1.4带servlet-api.jar而Java EE 5不带servlet-api.jar导致的问题,你把\tomcat\lib里面的servlet-api.jar文件拷贝到\Java\jdk1.6.0\lib中,并在classpath中添加servlet-api.jar,这样应该行。

JSP页面顶端出现“红色”的报错信息:The superclass "javax.servlet.http.HttpServlet" was not found on the Java Build Path。原来Javaweb工程类中没有添加Tomcat运行时相关类导致。 下面是具体的解决方法: 1、右击web工程-》属性或Build Path...

不支持的类版本错误 UnsupportedClassVersionError 版本不对,您再看看,谢谢~~~~

网站地图

All rights reserved Powered by www.ctrt.net

copyright ©right 2010-2021。
www.ctrt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com