www.ctrt.net > spring4必须jDk1.8么

spring4必须jDk1.8么

可以用maven下载,很方便。 org.springframeworkspring-context4.1.4.RELEASEorg.springframeworkspring-orm4.1.4.RELEA...

不是必须的,spring 4.x支持java 8的特性,但是保持向下的兼容性,最小支持为 java 6 ,但是建议使用java 7 或8 参考官网http://docs.spring.io/spring/docs/current/spring-framework-reference/htmlsingle/#_java_8_as_well_as_6_and_7 Spring ...

不是的,spring4开始支持jdk8的某些特性,但是也能使用jdk8之前的版本编写程序,并没有对之前的java版本完全废弃支持,但是里面的一些API被废弃了。具体的可以参看spring4的官方文档,看官方文档比较权威,网上搜的很多都变味儿了

spring 4.x

现在主流版本是jdk1.6,这个版本比较稳定而且1.6版本算是现在jdk内容用的最普遍的一个,包含了1.4的nio,包含了注解,包含线程同步的加强。 学习java EE知识规划: 重点学习:JSP Servlet javabean struts2.0 JDBC jQuery Ajax XML 次重点: Javasc...

请去spring.io查spring 4.0 release notes, 好像4.0最低要求jdk6, 何止是支持,低于jdk6都不行的

看我代码

:您那边可以升级spring2到spring3版本,这样应该就支持了,如果还是有问题的话,可以降低jdk1.8到1.7版本就可以了。现在的jdk1.8版本还没有用到普遍的开发中,可以考虑用低版本

jsp文件代码有错误埃 把jsp代码贴上来看一下

是spring框架吗,只要代码和配置文件没问题就能运行,代码最后编译成.class文件,在tomcat里运行,或者说是spring的开发环境有:eclipse tomcat jdk

网站地图

All rights reserved Powered by www.ctrt.net

copyright ©right 2010-2021。
www.ctrt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com